Live - Record processing delayed for some customers

Incident Report for SafetyChain

Resolved

This incident has been resolved
Posted Feb 06, 2025 - 18:26 EST

Investigating

We are currently investigating an incident in the Live environment where Record processing is delayed for some customers.
Posted Feb 06, 2025 - 15:32 EST
This incident affected: Record Processing.