Supplier portal unavailable for some customers

Incident Report for SafetyChain

Resolved

This incident has been resolved and the supplier portal and creating new supplier requirements are working for all users.
Posted Dec 20, 2024 - 10:27 EST

Update

We have received reports of customers not being able to create new supplier requirements. Our Engineering team is continuing its investigation.
Posted Dec 20, 2024 - 10:10 EST

Investigating

We are currently investigating an incident in the Live environment where the Supplier Portal may not be loading for some customers.
Posted Dec 20, 2024 - 09:45 EST