Live - Record processing delayed for some customers

Incident Report for SafetyChain

Resolved

This incident has been resolved
Posted Jul 02, 2025 - 23:38 EDT

Monitoring

A fix has been implemented and we are continuing to monitor the results.
Posted Jul 02, 2025 - 20:00 EDT

Investigating

We are continuing to investigate this issue.
Posted Jul 02, 2025 - 19:59 EDT

Monitoring

A fix has been implemented and we are continuing to monitor the results.
Posted Jul 02, 2025 - 19:28 EDT

Update

We are continuing to investigate the issue. LINK and Web have been restored, and the restoration of other services is in progress.
Posted Jul 02, 2025 - 19:01 EDT

Update

We are continuing to investigate the issue.
Posted Jul 02, 2025 - 17:01 EDT

Investigating

We are currently investigating an incident in the Live environment where Record Processing, Record Signoff, and Task Creation is delayed for some customers.
Posted Jul 02, 2025 - 15:31 EDT
This incident affected: Web, LINK, Mobile / Windows App, API Integrations/DPT, Record Processing, Record Signoff, Tasks, and Notifications.