Live - Login Disruptions

Incident Report for SafetyChain

Resolved

Login services have been restored and SafetyChain is now working for all users.
Posted Aug 13, 2024 - 15:17 EDT

Investigating

We are investigating reports of users not being able to log in to the Live environment.
Posted Aug 13, 2024 - 14:59 EDT
This incident affected: Web and LINK.