Login Disruption: Can't login to the SafetyChain system

Incident Report for SafetyChain

Resolved

The incident from February 20, 2025 has been resolved.
Posted Feb 21, 2025 - 10:01 EST

Update

Systems are stable, and performance has returned to normal. Our Engineering team is continuing to monitor, ensuring sustained performance. Reminder, Offline mode is functional and available when needed. You can enable airplane mode on your device and log in if you have previously logged in to that device. When submitting records, they will be placed in a pending status. The date and time of submission, as recorded in offline mode, will be reflected in LINK once the records are processed.
Posted Feb 20, 2025 - 15:37 EST

Update

We are continuing to closely monitor this incident while addressing additional improvements.
Posted Feb 19, 2025 - 21:38 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2025 - 13:24 EST

Update

Offline mode is functional. You can enable airplane mode on your device and log in if you have previously logged in to that device.
When submitting records, they will be placed in a pending status. However, the date and time of submission, as recorded in offline mode, will be reflected in LINK once the records are processed.
Posted Feb 19, 2025 - 10:54 EST

Update

Intermittent login disruptions may be encountered. Our Engineering team is actively working to rectify this as quickly as possible.
Posted Feb 19, 2025 - 10:28 EST

Investigating

We are investigating reports of users not being able to log in to the Live environment.
Posted Feb 19, 2025 - 08:59 EST
This incident affected: Web, LINK, Mobile / Windows App, API Integrations/DPT, Record Processing, Record Signoff, OEE, Tasks, and Notifications.