Login Disruption: Can't login to the SafetyChain system

Incident Report for SafetyChain

Resolved

This incident has been resolved
Posted Feb 19, 2025 - 08:17 EST

Monitoring

The SafetyChain platform experienced a login disruption from approximately 2:25 to 2:36 PM PT.

The service has been reestablished and we are continuously monitoring.
Posted Feb 18, 2025 - 17:38 EST