Live/Train - Field dependencies are not triggering as intended when completing submissions in the Browser

Incident Report for SafetyChain

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 09:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2026 - 08:58 EDT

Identified

We have identified an issue where Field dependencies are not evaluating properly if they are triggered a second time while filling out submissions in the Browser.
Posted Aug 19, 2026 - 14:13 EDT
This incident affected: Web.