Live - Record processing delayed for some customers

Incident Report for SafetyChain

Resolved

This incident has been resolved.
Posted Nov 25, 2024 - 10:18 EST

Investigating

We are currently investigating an incident in the Live environment where Record processing is delayed for some customers.
Posted Nov 25, 2024 - 09:55 EST
This incident affected: Record Processing, Record Signoff, and Tasks.