Live - API Integration Performance Degradation

Incident Report for SafetyChain

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 10:14 EDT

Monitoring

A fix has been implemented and we are actively monitoring the results to ensure this incident is resolved.
Posted Sep 02, 2025 - 13:31 EDT

Investigating

We are currently investigating an incident in the Live environment where API integration calls are experiencing performance degradation.
Posted Sep 02, 2025 - 13:28 EDT
This incident affected: API Integrations/DPT.